Armored House Quest ..?

Hey there, welcome to the Metin2.SG forum, here you can find a lot of interesting stuff, why don't you register your account? It only takes a minute! Click on the "Forum Login or forum-register" button on the top-left corner!


  • [CoMa]Shadow

    Yes some players reported this already, but sadly we can't reproduce it with our accounts or player's account too. So is going to take some time to fix this

  • buryzencio

    Shadow i found a glitch. While we have opened shop box window and we mount our horse and go few meters forward we getting kick from server.

  • [CoMa]Shadow

    Make a good report with screens, if it is a bug we will fix it as we always do

  • jureczek

    bug or something?

  • jureczek

    no monsters at final boss on nemere

  • KillerBambi


  • Renzeo

    are their specific times for server reboots/restarts?

  • AstonJunior

    Melysa is here somewhere?

  • [CoMa]Shadow

    Yes jureczek, remember that you can always pm me in case you need help, as the shoutbox doesn't offer the same level of privacy

  • Lacex54


  • jureczek

    shadow are you here?

  • Lacex54

    Can i pls get an Avatar unbann wanna upload my muscles dir the haterzz!!!

  • Lacex54

    The God is here BRAH! :borg:

  • [CoMa]Shadow

    if crit, is 40x. So is normal that he deals high amount of damage

  • [CoMa]Shadow

    It is not a bug BuffMausal, it is how the boss work, he has two skills, one of them is called DeathBlow, which inflicts 20x normal damage

  • BuffMausal

    pls fix that, that's so annoying ;(

  • BuffMausal

    NICE Shadow, now i get again crits from Razador :dash:

  • beckmen

    anyways just wanted to report it, not a big drama

  • beckmen

    but i dont remember die on my spots farming, and after update / reboot i suddenly die nearly every tank

  • [CoMa]Shadow

    The monsters are the same as prior the bug.

  • :thumbsup:
  • :airborne:
  • :assaultrifle:
  • :banned:
  • :bday:
  • :beer:
  • :blackeye:
  • :borg:
  • :censored:
  • :chainsaw:
  • :chinese:
  • :chrome:
  • :cookie:
  • :crazy:
  • :dance:
  • :dash:
  • :dead:
  • :doofy:
  • :evilgrin:
  • :fie:
  • :gamer:
  • :golly:
  • :growup:
  • :grumble:
  • :hail:
  • :hi:
  • :hmm:
  • :huntsman:
  • :ill:
  • :lol:
  • :miffy:
  • :minigun:
  • :misslelauncher:
  • :modo:
  • :monster:
  • :ninja:
  • :nono:
  • :oops:
  • :pardon:
  • :phatgrin:
  • :pillepalle:
  • :pleasantry:
  • :popcorn:
  • :puke:
  • :pump:
  • :rocketlauncher:
  • :rofl:
  • santa
  • :search:
  • :shit:
  • :sniper:
  • :spiteful:
  • :stick:
  • :stopping:
  • :thinking:
  • :this:
  • :topicclosed:
  • :vain:
  • :wayne:
  • :wbb:
  • :werderw:
  • :xeno:
  • :zombie:
  • :)
  • :(
  • ;)
  • :P
  • ^^
  • :D
  • ;(
  • X(
  • :*
  • :|
  • 8o
  • =O
  • <X
  • ||
  • :/
  • :S
  • X/
  • 8)
  • ?(
  • :huh:
  • :rolleyes:
  • :love:
  • 8|
  • :cursing:
  • :thumbdown:
  • :thumbup:
  • :sleeping:
  • :whistling:
  • :evil:
  • :saint:
  • <3
  • :!:
  • :?:
  • Good Evening Guys,

    my problem is, that I think that I have declined the Questline for the armored house. My Horse is already lv. 10 and I already tried the Armored House Quest twice. But as I realized that I won't gonna make it I decided to decline the Quest, because I thought that I can restart it.

    The Stable Boy doesn't offer me the possibility to do the quest. And If I want to click "Train your Horse" he says:
    Your Horse doesn't need no training anymore. Try to take the Armored house test

    My Question know:

    What can I do? Is it Worse?

    I already tried to PN a Gamemaster but I don't know who is online. The Live Support is offline and I already have written a Ticket.

    Hope for helpfull answers


  • You can't decline the horse quests. You can fail them but they will be never lost forever.

    You have failed a quest and of course you must read the scroll before you can attempt a new quest. So press CTRL +Q to display the scrolls, and click on it, or just click on all of them.

  • show a screen with options that stable boy offers you.
    maybe you already did the quest and if u failed you can try it again, if u succeded u have to wait some hours until ur armed horse painting is ready.
    if its lvl 10 , I think you have to press 'I want to improve my horse' not "I want to train my horse'.
    goodluck and u ll fix it :) take care

    Never gave in
    Never gave up
    Im the only thing im afraid of.